* *

Author Topic: 2 Brothers exhaust and Factory Pro jet kit issue. between 3-4K RPM.  (Read 739 times)

Offline CanaBandit

  • Board Regular!
  • **
  • Posts: 10
So over the winter I installed a new 2 Brothers exhaust and Foctory Pro jet kit in my 2005 Bandit 1200S.

I installed the 97.5 main jet and positioned the needle height at the third clip with the adjustment screws 2.5 turns out.

So I took it for it's first ride the other day.  Started well and idles nicely.  Warmed it up a bit (it was about 8 degrees C or 46 degrees F) 

Was smooth up until 3k RPM.  Then the bike struggles between 3 and 4k RPM.  After that it was good and accelerated strong.  I didn't really get a chance to do much WOT as the roads here have a lot of sand on them yet from the winter.  But every time I accelerate through 3-4 k RPM the bike hesitates to build RPM no matter the throttle position.

Any ideas out there?  The instructions with the jet kit say something about possibly raising the float height by 1mm if it feels wet and soggy in this area....  I don't really know if that's the case.  I did set them at 15mm as per the instructions initially.

Just looking at ideas before I tear the carbs out again....  A friend thinks it may be because there is too little back pressure with the open exhaust causing it.
« Last Edit: March 20, 2016, 01:26:08 PM by CanaBandit »

 

Sponsorship

Ad

Facebook

Welcome, Guest. Please login or register.
October 23, 2017, 04:42:49 AM

Login with username, password and session length

Recent